Saturday, February 6, 2010

NAT/PAT

Hi..I made NAT server that mapping/translation networks with single IP address.




CPE Router Configuration:
CPE#show run
Building configuration...

Current configuration : 1313 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CPE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
ip address 11.0.0.1 255.255.255.0
ip nat outside
ip virtual-reassembly
serial restart-delay 0
clock rate 64000
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet1/0
ip address 192.168.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly
half-duplex
!
interface Ethernet1/1
ip address 192.168.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
ip http server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial0/0
!
ip nat pool abc 11.0.0.1 11.0.0.1 netmask 255.255.255.0
ip nat inside source list 1 pool abc overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CPE#

No comments:

Post a Comment