Hello!!
Here I post something new in frame-relay for me today i learn. It is just NNI protocols that route frame relay frame between switches to switches.
NNI means Network-to-Network Interface protocol.
In Frame Relay Three types of mainly interfaces available
(1) DTE- Data Terminal Equipement
(2) DCE- Data Communication Equipement
(3) NNI- Network-to-Network Interface
Here below you See Image.
Now See Configurations
hostname FRS1
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
no fair-queue
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 301
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 301 interface Serial1/0 102
!
_______________________________________________
hostname FRS2
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
no fair-queue
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial1/1 301
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 301 interface Serial1/0 201
!
_______________________________________________
hostname R1
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 10.0.0.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.0.0.1 102
frame-relay map ip 10.0.0.2 102 broadcast
frame-relay interface-dlci 102
!
____________________________________________
hostname R2
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 10.0.0.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.0.0.1 201 broadcast
frame-relay map ip 10.0.0.2 201
frame-relay interface-dlci 201
!
Thank you,
Regards,
Jignesh
hi thanks for sharing im stuck here, i dont see where u assign the dlci 301?
ReplyDelete